Формула в excel если значение меньше 0 то равно 0

Формула в excel если значение меньше 0 то равно 0

Как заменить в Excel отрицательное число на ноль.

​ нашим условиям. Смотрите​ логического выражения. Смотрите​В ячейку В6​ =ЕСЛИ(А1=2;6;0)​ написали условие, по​​ слово, посчитай сумму​ ​ =ЕСЛИ(A2-B2​ в разделе «Библиотека​​в Excel заменить цифру,​
​ пишешь =если (В1>0;B1)​ цветов, через «создать​ с ячейки А2​ знаком минус (​ цвет шрифта);​ параметры для следующего​=A1-B1​ применений этих функций.​ статью «Функция «СЧЁТЕСЛИ​ такую формулу в​ написали такую формулу.​Копируем формулу вниз​
​ которому нужно искать​ таких-то ячеек, т.д.​Третий вариант.​ функций» выбираем «Другие​ значение на ноль,​в ячейке С2​ правило».​ ​ и А1​-​Теперь нулевые значения отображаются​ листа/, затем снять​Выделите ячейку​

​Еще одна логическая​ в Excel». Эту​ статье «Функция «ЕСЛИ»​ =ЕСЛИ(A6=»%»;1;»нет») Здесь в​ по столбцу В.​ ячейки в столбце​ Все это пишем​В новом столбце​ функции». Затем выбираем​в т.ч.​

​ пишешь =если (В1​
​Ampersand​​Dimon​​), то в ячейке​ белым шрифтом и​ галочку Показывать нули​С1​ функция в Excel​ функция может посчитать​ в Excel с​ третьем условии написали​ ​ Получилось так.​
​ А (ячейки, в​ в формуле. Функция​ пишем формулу. В​ функции «Статистические» и​отрицательное число​Вывод значения или 0​

​: ПОЛЬЗОВАТЕЛЬСКИЙ ФОРМАТ​: по-моему выглядеть она​ должно отображаться​ не видны на​ в ячейках, которые​, зажмите её правый​
​ – это функция​ ячейки, в которых​ несколькими условиями сравнения».​ слово «нет» в​Только в ячейке В2​ которых стоит цифра​ в Excel «ЕСЛИ»​ примере мы напишем​ нажимаем на функцию​

Функция «ЕСЛИ» в Excel.

Как изменить отрицательные числа на нули в Excel

​ нуля, то значение​ открыто. ​ в ячейке останется​ (например, введите формулу​ формат # ##0,00;-# ##0,00;​MAX​ хитром трюке, с​ определенных строках».​

​ в Excel вставлять​ Если число будет​ «Да». В ячейке​ любое слово в​ В то значение,​​ «Отрицательные числа Excel​​ цифру в столбце​ отрицательное число в​​: простите меня сирого. ​​ записывается в С1,​

  1. ​Зачем вам​​ отрицательное число.​​ =»»). Записав, например,​
  2. ​Применение вышеуказанного формата не​

​(МАКС) возвращает максимальное​

​ помощью которого можно​​Можно в Excel​​ в другие формулы​ меньше 2, то​ В4 написали такую​

​ этом условии, т.д.​

​ которое мы укажем​ в скобках».​ или строке. Например,​ ноль, нужно воспользоваться​ если(формула>0;формула;0) делов то​

​ если меньше нуля,​

​Подскажите как сделать написать​
​ в ячейке​

​ влияет на вычисления.​ из двух значений.​

​ изменить отрицательные числа​​ суммировать данные из​​ с другими функциями.​​ ячейка должна оставаться​ формулу.​Третье условие –​ в формуле. Можно​Часто применяемая,​

​ узнаем какая цифра​ функцией «МАКС». У​
​AndreTM​
​ то в С2.​

​пишешь фразу «условное​

Скрытие значений в MS EXCEL равных 0

​ формулу если :​B1​ В Строке формул,​

​ Если результат формулы​ на нули, при​ таблицы по многим​=ЕСЛИОШИБКА(ИНДЕКС($B$2:$B11;НАИМЕНЬШИЙ(ЕСЛИ($F$2=A2:A11;СТРОКА(B2:B11)-1;»»);​ пустой. Скопировали формулу​=ЕСЛИ(A4=»Да»;100;»»)​ «Значение_если_ложь» — здесь​ выбрать любые числа,​логическая функция в Excel​ самая большая в​ нас такая таблица.​

​:​ Как такое реализовать?​ форматирование» / «conditional​ нужно чтобы, если​формулу =ЕСЛИ(A1;A1;»») получим​ по-прежнему, будет отображаться​

Пользовательский формат

​ отрицательный, функция возвращает​ этом оставив неизменными​ разным условиям. Например,​

  • ​СТРОКА()-5));»»)​ по столбцу С.​​Обратите внимание!​​ мы напишем, что​
  • ​ слова, т.д.​
  • ​ — функция «ЕСЛИ»​ строке 2. В​

​Здесь из первого​Вывод значения или 0,​Zenya petrusev​ formatting»​ вычислениt с двух​ пустую ячейку​ 0, хотя в​

Условное форматирование

​ 0.​ положительные.​ в функции «ЕСЛИ»​

  • ​Эта формула для​
  • ​ Получилось так.​В третьем условии​ нужно писать, если​Появившееся диалоговое окно​
  • ​считает данные ячеек​ ячейку E2 пишем​
  • ​ столбца А вычислили​вам придётся вычислять​: Если ты пишешь​

​читаешь​ ячеек больше нуля,​В1​ ячейке ничего не​

​Урок подготовлен для Вас​На рисунке ниже вы​ можно написать одно​ примера взята из​Пятый пример.​ в формуле мы​ в ячейке А1​ заполнили так.​ по условию, которое​ такую формулу =МАКС(A2:D2)​ второй столбец В.​

Значение Пустой текст («»)

​ (и записывать!) формулу​ программу, то это​PROFIT!​ тогда в ячейке​в случае, если​ будет отображаться.​ командой сайта office-guru.ru​​ видите два столбца​​ условие поиска данных​ статьи «Выбрать сразу​​Можно функцией «ЕСЛИ»​​ поставили не «нуль»,​ будет написано НЕ​​В формуле «ЕСЛИ» нужно​​ мы напишем в​ Получилось.​​ Теперь нам нужно,​​ два раза, а​

Если число отрицательное, то 0 (Формулы/Formulas)

​ просто сделать, команды​​в 2007 экселе​
​ формулы писалась эта​ в​​Используя Условное форматирование, также​​Источник: http://www.excel-easy.com/examples/negative-numbers-to-zero.html​ с цифрами. Чтобы​​ для суммирования. В​​ много данных из​ посчитать итог теста,​​ а две двойные​​ цифра «2», а​
​ написать три условия.​ формуле или пишет​

​Второй вариант.​​ чтобы в таблице​ ​ если она длиной​

​ зависят от языка​​ есть кнопка с​ сумма, а если​А1​ можно добиться практически​Перевел: Антон Андронов​ вычесть числа в​ функции «СУММЕСЛИМН» можно​ таблицы Excel» здесь.​ когда в нем​ кавычки – это​

Формула «если» в Excel

​ другая цифра. Мы​ В формуле эти​ нужные слова в​Нам пригодится​Excel​ в сотню-другую символов?​Александр погребняк​ таким названием на​ меньше нуля тогда​находится значение =0.​ такого же результата.​Автор: Антон Андронов​

​ столбце​​ написать в одной​ Этой формулой выбираем​
​ ставят не слова,​ значит «Пусто» (оставить​ поставили «0» (нуль).​ условия напишутся через​ нужной ячейке. Например,​

​функция «ЕСЛИ» в Excel​​вместо отрицательных чисел стоял​ а если в​: Средствами Эксель этого​
​ закладке Home​ просто ноль. например:​ Столбец​выделите интересующий диапазон;​
​Иногда требуется скрыть значения​В​ формуле до 127​ из таблицы товара​ а знаками. Читайте​ ячейку пустой). Скопировали​ Это значит, если​ точку с запятой.​ такие условия -​. Эта функция находится​ нуль​

Вопрос по Excel. Как сделать так, что бы если значение ячейки меньше нуля, то значение окрашивалось в красный цвет?

​ ней надо что-то​​ сделать нельзя. Ни​
​вобщем, там всё​ 5,82-5,10 = 0,72;​А​
​в меню выберите Главная/​
​ равные 0. Сделаем​
​из чисел в​ условий. Подробнее об​ и переносим в​ статью «Как объединить​
​ формулу в ячейку​ в ячейке А1​

​Первое условие –​​ если в ячейке​
​ на закладке «Формулы»,​.​
​ исправить?​
​ одна формула не​ интуитивно понятно​ 5,10-5,82=0; . ​

​можно скрыть.​​ Стили/ Условное форматирование/​
​ это несколькими способами.​
​ столбце​
​ этой функции, ее​
​ лист заказа выбранные​
​ данные теста в​
​ В5.​ стоит НЕ цифра​ «Лог_выражение». Мы написали​ А стоит то-то,​
​ в разделе «Библиотека​В новом столбце​
​Так что воспользуйтесь​

Если значение больше нуля то разность пишем в одну ячейку если меньше то в другую

​ может изменить значение​Владимир шулдяков​Rover​Steve​ Правила выделения ячеек/​Скрыть значения равные 0​А​ применении и различных​ покупателем позиции.​

​ ячейках в Excel»​​Третий пример.​ «2», то Excel​ А1=2 – это​ а в ячейке​

​ функций» выбираем –​​ (у нас в​ вышеприведенным ответом от​ в другой ячейке.​: 2010​: Вот так =ЕСЛИ​
​: Доброго времени суток!​ Равно);​

​ во всех ячейках​​, следуйте инструкции.​ вариантах применения, читайте​
​Ещё есть функция​ тут.​

если результат формулы отрицательный (Формулы)

​В следующей формуле​​ должен написать в​ значит, если в​ В стоит то-то,​ «Логические». Или просто​ примере, в столбце​

​Формуляр​​Нужно только на​ ​Вкладка «главная» -​
​ (RC[-2]-RC[-1]>0;RC[-2]-RC[-1];0)​Если сумма из​в левом поле введите​
​ на листе можно​

​Выберите ячейку​​ в статье «Суммирование​ «СЧЁТЕСЛИ» в Excel​
​Можно в Excel​

​ поставили в третьем​​ ячйке В1 нуль.​ ячейке А1 стоит​

​ то в ячейке​​ пишем такую формулу​​ D) пишем формулу.​​. ​ ВБА макрос писать​ «условное форматирование»​Это выражение помещается​ двух ячеек​ 0;​ через Параметры MS​С1​
​ ячеек в Excel​ — она считает​​ в функцию «ЕСЛИ»​​ условии знак «Тире».​

Блог Евгения Крыжановского

Я научу вас ремонтировать свой компьютер!

Excel: «Если» (формула). В Excel функция «Если»

В статье речь пойдет о функции табличного редактора Excel «Если». Она связана с логическими возможностями приложения. Данную функцию можно отнести к наиболее распространенной, которая зачастую используется во время работы.

Ключевые возможности

В программе Excel формула «Если» позволяет различного рода задачи, которые требуют сравнить определенные значения и получить результат. Такое решение дает возможность использовать ветвящиеся алгоритмы, создавать дерево решений.

Примеры применения

Функция имеет вид: =ЕСЛИ (задача; истина; ложь). Первой составной частью является логическое выражение. Оно способно выступать в виде фразы или числа. Например, «10» или «без НДС». Такой параметр обязательно следует заполнить. Истина представляет собой значение, отображающееся в качестве результата, если выражение верно. Ложь представляет собой данные, которые будут выданы, когда задача неверна.

Равенство параметров двух ячеек

Чтобы лучше понять возможности функции «Если» в Excel, необходимо привести примеры. Поэтому дальше стоит приступить к их рассмотрению. Нужно ввести в клетку C1 значение 8. После этого в поле по адресу D1 необходимо вписать формулу вида: =ЕСЛИ(C1 , =, >, =, 3); «проходит», «нет»).

Если рассмотреть более сложный пример, понадобится использовать «ИЛИ» либо «И». Таким образом, можно ознакомиться с применением формулы в Excel, если существует несколько условий в задании. Например: =ЕСЛИ(ИЛИ(A1=5; A1=10); 100; 0). В данном случае можно сделать вывод, когда значение в клетке А1 равно 5 или 10, программа отображает результат 100. В противном случае он составляет 0. Существует возможность применить эти операторы, чтобы найти решение более сложным задачам.

Например, в базе требуется вычислить должников, которым требуется заплатить более 10000 рублей. Можно задать условие, что заем не погашался более полугода, то есть шести месяцев. Благодаря функции табличного редактора Excel «Если» позволяется в автоматическом режиме получить около соответствующих имен отметку «проблемный клиент». Допустим, в клетке A1 размещены данные, которые указывают на срок задолженности (месяцы). Поле B1 содержит сумму.

В данном случае формула представлена в следующем виде: =ЕСЛИ(И(A1>=6; B1>10000); «проблемный клиент»; «»). Таким образом, если выявлен человек, соответствующий указанным условиям, программа отображает напротив его имени соответствующий комментарий. Для других участников списка эта клетка останется пустой.

Также можно ознакомиться с примером, когда ситуация является критической. Необходимо ввести соответствующий комментарий. Как результат, формула получится следующей: =ЕСЛИ(ИЛИ(A1>=6; B1>10000); «критическая ситуация»; «»). Однако если программа определяет совпадения по одному из параметров как минимум, отображается соответствующее примечание.

Сложные задачи

Функция Excel «Если» применяется для того, чтобы избежать встроенных ошибок при делении на ноль. Кроме того, она используется и в некоторых других ситуациях. Первый случай обозначается, как «ДЕЛ/0». Его можно встретить достаточно часто. Обычно это происходит тогда, когда формула «A/B» требует копирования. В это же время показатель B в отдельных ячейках составляет 0. Чтобы избежать подобной ситуации, стоит использовать возможности рассматриваемого оператора. Таким образом, требуемая формула имеет следующий вид: =ЕСЛИ(B1=0; 0; A1/B1). Итак, если клетка B1 заполнена значением «ноль», редактор отобразит «0». В противном случае программа поделит показатель A1 на данные B1 и выдаст требуемый результат.

Скидка

Как показывает практика, зачастую возникают ситуации, которые рассматриваются далее. Потребуется рассчитать скидки, учитывая общую сумму средств, затраченных на покупку конкретного товара. Матрица, которая используется, выглядит следующим образом: менее 1000 — 0%; 1001-3000 — 3%; 3001-5000 — 5%; более 5001 — 7%. Можно ознакомиться с ситуацией, когда в Excel имеется база данных посетителей и сведения о сумме, потраченной на покупку. Далее следует рассчитать скидку для каждого клиента. Для этого понадобится применить следующее выражение: =ЕСЛИ(A1>=5001; B1*0,93; ЕСЛИ(А1>=3001; B1*0,95;..).

Система выполняет проверку общей суммы покупок. Если она превышает значение в 5001 рублей, выполняется умножение на 93 процента цены товара. Если превышена отметка в 3001 единиц, происходит аналогичное действие, однако уже учитывается 95%.

Запись опубликована 17.09.2015 автором katrinas11 в рубрике Программы. Отблагодари меня, поделись ссылкой с друзьями в социальных сетях:

Функция ЕСЛИ() в MS EXCEL

Функция ЕСЛИ() относится к наиболее часто используемым функциям.

Синтаксис функции

ЕСЛИ(лог_выражение;значение_если_истина;[значение_если_ложь])

Лог_выражение — любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ.
=ЕСЛИ(A1>=100;»Бюджет превышен»;»ОК!»)
Т.е. если в ячейке A1 содержится значение большее или равное 100, то формула вернет ОК!, а если нет, то Бюджет превышен.

В качестве аргументов функции, могут участвовать формулы, например:
=ЕСЛИ(A1>100;СУММ(B1:B10);СУММ(C1:C10))
Т.е. если в ячейке A1 содержится значение >100, то суммирование ведется по столбцу B, а если меньше, то по столбцу С.

Вложенные ЕСЛИ

В EXCEL 2007 в качестве значений аргументов значение_если_истина и значение_если_ложь можно для построения более сложных проверок использовать до 64 вложенных друг в друга функций ЕСЛИ() .
=ЕСЛИ(A1>=100;»Бюджет превышен»;ЕСЛИ(A1>=90;»Крупный проект»;ЕСЛИ(A1>=50;»Средний проект»;»Малый проект «)))

Вышеуказанную формулу можно усложнять и дальше, но есть другие подходы:

Для функции ВПР() необходимо создать в диапазоне A3:B6 таблицу значений:

Если требуется вывести разный текст в случае наличия в ячейке А1 отрицательного значения, положительного значения или 0, то можно записать следующую формулу:

или, если требуется вместо текстовых значений вывести формулы, можно использовать ссылки на диапазон ячеек (содержащих формулы)

=ПРОСМОТР(A24;<-1E+307;0;1E-307>;A27:A29) (см. файл примера )

Опущен третий аргумент [значение_если_ложь]

Третий аргумент функции не обязателен, если его опустить, то функция вернет значение ЛОЖЬ (если условие не выполнено).
=ЕСЛИ(A1>100;»Бюджет превышен»)
Если в ячейке A1 содержится значение 1, то вышеуказанная формула вернет значение ЛОЖЬ.

Вместо ИСТИНА или ЛОЖЬ в первом аргументе введено число

Т.к. значение ЛОЖЬ эквивалентно 0, то формулы
=ЕСЛИ(0;»Бюджет превышен»;»ОК!»)
или (если в ячейке A1 содержится значение 0)
=ЕСЛИ(A1;»Бюджет превышен»;»ОК!»)
вернут ОК!

Если в ячейке A1 находится любое другое число кроме 0, то формула вернет Бюджет превышен. Такой подход удобен, когда проверяется равенство значения нулю.

Связь функции ЕСЛИ() с другими функциями использующие условия

EXCEL содержит также другие функции, которые можно применять для анализа данных с использованием условий. Например, для подсчета количества вхождений чисел в диапазоне ячеек используется функция СЧЁТЕСЛИ() , а для сложения значений, удовлетворяющих определенным условиям, используется функция СУММЕСЛИ() .

Функция ЕСЛИ() , как альтернативный вариант, может быть также использована для подсчета и сложения значений с использованием условий. Ниже приведены иллюстрирующие примеры.

Пусть данные находятся в диапазоне A6:A11 (см. файл примера)

Подсчитаем сумму значений, которые больше 10 с помощью функции СУММЕСЛИ() , записав =СУММЕСЛИ(A6:A11;»>10″) . Аналогичный результат (23) можно получить с помощью формулы массива
=СУММ(ЕСЛИ(A6:A11>10;A6:A11))
(для ввода формулы в ячейку вместо ENTER нужно нажать CTRL+SHIFT+ENTER)

Теперь подсчитаем количество вхождений чисел больше 10 в диапазоне ячеек A6:A11 =СЧЁТЕСЛИ(A6:A11;»>10″) . Аналогичный результат (2) можно получить с помощью формулы массива
=СЧЁТ(ЕСЛИ(A6:A11>10;A6:A11))

Теперь, когда принцип понятен, с помощью функции ЕСЛИ() можно конструировать и другие формулы с условиями. Например, нахождение минимального значения среди чисел больше 10:
=МИН(ЕСЛИ(A6:A11>10;A6:A11))

Функции Excel ЕСЛИ (IF) и ЕСЛИМН (IFS) для нескольких условий

Логическая функция ЕСЛИ в Экселе – одна из самых востребованных. Она возвращает результат (значение или другую формулу) в зависимости от условия.

Функция ЕСЛИ в Excel

Функция имеет следующий синтаксис.

ЕСЛИ(лог_выражение; значение_если_истина; [значение_если_ложь])

лог_выражение – это проверяемое условие. Например, A2 30) не выполняется и возвращается альтернативное значение, указанное в третьем поле. В этом вся суть функции ЕСЛИ. Протягивая расчет вниз, получаем результат по каждому товару.

Однако это был демонстрационный пример. Чаще формулу Эксель ЕСЛИ используют для более сложных проверок. Допустим, есть средненедельные продажи товаров и их остатки на текущий момент. Закупщику нужно сделать прогноз остатков через 2 недели. Для этого нужно от текущих запасов отнять удвоенные средненедельные продажи.

Пока все логично, но смущают минусы. Разве бывают отрицательные остатки? Нет, конечно. Запасы не могут быть ниже нуля. Чтобы прогноз был корректным, нужно отрицательные значения заменить нулями. Здесь отлично поможет формула ЕСЛИ. Она будет проверять полученное по прогнозу значение и если оно окажется меньше нуля, то принудительно выдаст ответ 0, в противном случае — результат расчета, т.е. некоторое положительное число. В общем, та же логика, только вместо значений используем формулу в качестве условия.

В прогнозе запасов больше нет отрицательных значений, что в целом очень неплохо.

Формулы Excel ЕСЛИ также активно используют в формулах массивов. Здесь мы не будем далеко углубляться. Заинтересованным рекомендую прочитать статью о том, как рассчитать максимальное и минимальное значение по условию. Правда, расчет в той статье более не актуален, т.к. в Excel 2016 появились функции МИНЕСЛИ и МАКСЕСЛИ. Но для примера очень полезно ознакомиться – пригодится в другой ситуации.

Формула ЕСЛИ в Excel – примеры нескольких условий

Довольно часто количество возможных условий не 2 (проверяемое и альтернативное), а 3, 4 и более. В этом случае также можно использовать функцию ЕСЛИ, но теперь ее придется вкладывать друг в друга, указывая все условия по очереди. Рассмотрим следующий пример.

Нескольким менеджерам по продажам нужно начислить премию в зависимости от выполнения плана продаж. Система мотивации следующая. Если план выполнен менее, чем на 90%, то премия не полагается, если от 90% до 95% — премия 10%, от 95% до 100% — премия 20% и если план перевыполнен, то 30%. Как видно здесь 4 варианта. Чтобы их указать в одной формуле потребуется следующая логическая структура. Если выполняется первое условие, то наступает первый вариант, в противном случае, если выполняется второе условие, то наступает второй вариант, в противном случае если… и т.д. Количество условий может быть довольно большим. В конце формулы указывается последний альтернативный вариант, для которого не выполняется ни одно из перечисленных ранее условий (как третье поле в обычной формуле ЕСЛИ). В итоге формула имеет следующий вид.

Комбинация функций ЕСЛИ работает так, что при выполнении какого-либо указанно условия следующие уже не проверяются. Поэтому важно их указать в правильной последовательности. Если бы мы начали проверку с B2 =1. Однако этого можно избежать, если в поле с условием написать ИСТИНА, указывая тем самым, что, если не выполняются ранее перечисленные условия, наступает ИСТИНА и возвращается последнее альтернативное значение.

Теперь вы знаете, как пользоваться функцией ЕСЛИ в Excel, а также ее более современным вариантом для множества условий ЕСЛИМН.

Функция ЕСЛИ в Excel с примерами нескольких условий

Логический оператор ЕСЛИ в Excel применяется для записи определенных условий. Сопоставляются числа и/или текст, функции, формулы и т.д. Когда значения отвечают заданным параметрам, то появляется одна запись. Не отвечают – другая.

Логические функции – это очень простой и эффективный инструмент, который часто применяется в практике. Рассмотрим подробно на примерах.

Синтаксис функции ЕСЛИ с одним условием

Синтаксис оператора в Excel – строение функции, необходимые для ее работы данные.

Разберем синтаксис функции:

Логическое_выражение – ЧТО оператор проверяет (текстовые либо числовые данные ячейки).

Значение_если_истина – ЧТО появится в ячейке, когда текст или число отвечают заданному условию (правдивы).

Значение,если_ложь – ЧТО появится в графе, когда текст или число НЕ отвечают заданному условию (лживы).

Оператор проверяет ячейку А1 и сравнивает ее с 20. Это «логическое_выражение». Когда содержимое графы больше 20, появляется истинная надпись «больше 20». Нет – «меньше или равно 20».

Внимание! Слова в формуле необходимо брать в кавычки. Чтобы Excel понял, что нужно выводить текстовые значения.

Еще один пример. Чтобы получить допуск к экзамену, студенты группы должны успешно сдать зачет. Результаты занесем в таблицу с графами: список студентов, зачет, экзамен.

Обратите внимание: оператор ЕСЛИ должен проверить не цифровой тип данных, а текстовый. Поэтому мы прописали в формуле В2= «зач.». В кавычки берем, чтобы программа правильно распознала текст.

Функция ЕСЛИ в Excel с несколькими условиями

Часто на практике одного условия для логической функции мало. Когда нужно учесть несколько вариантов принятия решений, выкладываем операторы ЕСЛИ друг в друга. Таким образом, у нас получиться несколько функций ЕСЛИ в Excel.

Синтаксис будет выглядеть следующим образом:

Здесь оператор проверяет два параметра. Если первое условие истинно, то формула возвращает первый аргумент – истину. Ложно – оператор проверяет второе условие.

Примеры несколько условий функции ЕСЛИ в Excel:

Таблица для анализа успеваемости. Ученик получил 5 баллов – «отлично». 4 – «хорошо». 3 – «удовлетворительно». Оператор ЕСЛИ проверяет 2 условия: равенство значения в ячейке 5 и 4.

В этом примере мы добавили третье условие, подразумевающее наличие в табеле успеваемости еще и «двоек». Принцип «срабатывания» оператора ЕСЛИ тот же.

Расширение функционала с помощью операторов «И» и «ИЛИ»

Когда нужно проверить несколько истинных условий, используется функция И. Суть такова: ЕСЛИ а = 1 И а = 2 ТОГДА значение в ИНАЧЕ значение с.

Функция ИЛИ проверяет условие 1 или условие 2. Как только хотя бы одно условие истинно, то результат будет истинным. Суть такова: ЕСЛИ а = 1 ИЛИ а = 2 ТОГДА значение в ИНАЧЕ значение с.

Функции И и ИЛИ могут проверить до 30 условий.

Пример использования оператора И:

Пример использования функции ИЛИ:

Как сравнить данные в двух таблицах

Пользователям часто приходится сравнить две таблицы в Excel на совпадения. Примеры из «жизни»: сопоставить цены на товар в разные привозы, сравнить балансы (бухгалтерские отчеты) за несколько месяцев, успеваемость учеников (студентов) разных классов, в разные четверти и т.д.

Чтобы сравнить 2 таблицы в Excel, можно воспользоваться оператором СЧЕТЕСЛИ. Рассмотрим порядок применения функции.

Для примера возьмем две таблицы с техническими характеристиками разных кухонных комбайнов. Мы задумали выделение отличий цветом. Эту задачу в Excel решает условное форматирование.

Исходные данные (таблицы, с которыми будем работать):

Выделяем первую таблицу. Условное форматирование – создать правило – использовать формулу для определения форматируемых ячеек:

В строку формул записываем: =СЧЕТЕСЛИ (сравниваемый диапазон; первая ячейка первой таблицы)=0. Сравниваемый диапазон – это вторая таблица.

Чтобы вбить в формулу диапазон, просто выделяем его первую ячейку и последнюю. «= 0» означает команду поиска точных (а не приблизительных) значений.

Выбираем формат и устанавливаем, как изменятся ячейки при соблюдении формулы. Лучше сделать заливку цветом.

Выделяем вторую таблицу. Условное форматирование – создать правило – использовать формулу. Применяем тот же оператор (СЧЕТЕСЛИ).

Здесь вместо первой и последней ячейки диапазона мы вставили имя столбца, которое присвоили ему заранее. Можно заполнять формулу любым из способов. Но с именем проще.

Похожие статьи

Читать еще:  Сложить время в excel по формуле
Ссылка на основную публикацию
Похожие публикации
Adblock
detector